Text Viewer
The TableCurve Studio text viewer appears throughout the program for displaying, modifying, and printing text information.
Considerations
The text view window is used in the ASCII List option, the Evaluation Procedure in the View Function(X,Y) and Surface-Fit Review, the Numeric Summary, the Data Summary, and the Precision Summary in the Review, and also for the Surface-Fit Generated Code Output. The viewer can display up to 65536 lines of information. You may use either the cursor keys or the scroll bars to move about the text. If the contents of the view window have been generated by TableCurve Studio, the text will contain columnar formatting to properly align all fonts, there will be a predefined color formatting, and there will be support for displaying and printing subscripts, superscripts, and symbols.
File Menu
The viewer's File menu contains options to save the information in the window as an ASCII file (comma separated CSV, tab separated PRN, or space formatted TXT), as a fully formatted Rich Text Format (RTF) file, or the contents can be directly streamed to MS Word. The CSV format is the most practical choice for numeric columns of data that will be opened in a spreadsheet.
The RTF format preserves the appearance of the text when imported into word processing and desktop publishing products. The RTF option thus preserves columnar formatting, font colors, bolding, superscripts, and subscripts. In order to save, copy, or stream black and white RTF text, you will need to uncheck the Color option in the Style menu.
The Printer Setup item is used to select and optionally configure a printer for use by TableCurve Studio. Note that the orientation option in the printer driver's own configuration dialog will be overridden by the orientation set in the Text Print dialog.
The Print item opens the Text Print dialog, allowing a header to be specified, the date and page number to be included, the orientation to be chosen, and the margins to be set. You may also elect to center the longest line and to print either all information or only that portion currently visible in the window.
Edit Menu
The Copy option copies the text in the window to the Windows clipboard as unformatted text, as comma separated (CSV) text, and as formatted Rich Text Format (RTF) text. The unformatted text format is tab delimited and is used when you paste the information into a text-based program.
The RTF format seeks to exactly preserve the appearance of the text when pasted into word processing and desktop publishing products. The RTF format preserves columnar formatting, font colors, bolding, superscripts, and subscripts. In order to save a black and white RTF text file, you will need to uncheck the Color option in the Style menu prior to the Copy.
For some products where RTF is the default clipboard format, such as Microsoft Word, you will need to use a Paste As, Paste Special, or similar option in order to specifically select the unformatted text. When pasted into a spreadsheet, text containing columns of numeric information is separated into cells. This Copy option is limited only by available memory.
The ASCII Editor option copies the contents of the viewer into the TableCurve Studio ASCII editor.
Style Menu
The text windows each use their own specific font. If you select a different font using the Font Select item, it will be used only for the current type of text window. Since TableCurve Studio's internal windows are preformatted, you may freely select variable pitch fonts, although you may wish to use a fixed width font for the ASCII List and ASCII Editor options, especially when working with files containing numeric columns of data.
The Color item simply toggles the text between its predefined color format and the default black text on white. Although the information can be displayed in color, it is always printed in black and white. The font and color setting are saved across sessions for each type of window.