File Menu


Most of the File Menu options work with the TableCurve Studio Explorer to manage notebook files. Many of these options are also in the main toolbar. Depending on the item selected, they also appear within the TableCurve Studio Explorer on the right click popup menu.

Notebook Files

tree03.png New - closes the existing notebook and creates a new (empty) notebook file

loadsnb.png Open - closes the existing notebook and opens an SNB notebook file from disk

savesnb.png Save - saves the current notebook to disk (functions as Save As if no save as yet occurred)

     Save As - saves the current notebook to a new SNB notebook file

Adding Data Source and XYZ Specification

open2.png Import Data Source - adds a disk-based file containing one or more XYZ data sets to the current notebook

     Drag and Drop Files - adding data sources via drag and drop from Windows Explorer

specxyz.png Specify XYZ Data Item - creates an XYZ native data object by selecting the X, Y, Z columns.

specxyz2.png Autospecify all XYZ Data Items - automatically creates all XYZ data sets within a data source or a worksheet within a data source

     Import Special : Import Digital Filter - specifies the import filter settings for a data item

paste2.png Import Special : Import Clipboard - imports numeric data in clipboard columns, saves to disk, and adds file to notebook            

     Import Special : Import Clipboard Matrix - imports an XYZ data matrix, saves to disk, and adds file to notebook

TableCurve Studio Explorer Management            

     Rename Selected Item - allows the currently selected notebook item to be renamed

     Remove Selected Item - deletes the currently selected notebook item, including all child items that may be present.

tree05.png Copy - copies the currently selected XYZ data operation (a child of an XYZ data item that itself contains XYZ data)

tree06.png Paste - pastes the previously copied XYZ data operation to the current XYZ data item (creates a new XYZ child item)

     Collapse All Items - collapses all items in the notebook

     Expand All Items - full expands all items in the notebook

Annotation

     Add Annotation - adds ASCII text item to notebook

Exporting Current XYZ Data

saveas2.png Export XYZ - exports the current XYZ data to an ASCII, Excel, Lotus, SPSS, or Systat file.

Other File Menu Options

     ASCII List - lists any ASCII file with an option to open an ASCII editor.

     Reset All Defaults - restores all default program settings.

     Exit - closes TableCurve Studio

     Previous Files - the most recently used list of data sources are appended to the file menu.